New answers tagged

1

Try to change your AppPool Identity to ApplicationPoolIdentity Also if this doesn't help then change in Plugin.SQL.PolicySet-1.0.0.json "TrustedConnection": "false", and bootstrap then try. Do it for all 4 - Authoring, Shops, Minions, Ops.


1

When you install Sitecore Commerce then it adds a new binding for storefront. You can see the name in your Sitecore Commerce installation file "Deploy-Sitecore-Commerce.ps1". There you can find the hostname provided in "$SiteHostHeaderName" variable. Can you please double check if you can access your storefront with "http://sxa....


0

Khushant Dhingra's answer prompted me to check the settings for my Sitecore site. I have two hostnames: one for master DB and the other for web. The binding/hostname for the web DB (which is what PlugIn.Content.PolicySet-1.0.0.json was referencing) did not have a valid certificate assigned to it. This was evidenced by simply viewing the Sitecore site on the ...


2

Please check SitecoreConnectionPolicy in "PlugIn.Content.PolicySet-1.0.0.json" file in Commerce Engine Auth folder. Ensure it is correct. if not then fix it and do bootstrap again. Most probably this issue is due to incorrect Sitecore Connection Policy. Also check the same SitecoreConnectionPolicy in Global.json file.


2

It seems that the problem here was in my creation of the certificate. I used something like this to create the certificate (BAD): New-SelfSignedCertificate -CertStoreLocation "cert:\LocalMachine\My" -DnsName "localhost" -FriendlyName "Sitecore Commerce Services" -KeyUsage KeyEncipherment,DigitalSignature I fixed the problem ...


0

Yes, before start running the debugging in VS, you have to make sure that you have stopped your Website and related AppPool in IIS. Another option for debugging is "Attach to process". In case of CE, the difference is that you have to attach to the executable Sitecore.Commerce.Engine.exe process and not to the regular w3wp process.


0

Yes, it's possible to use a field type like RichText. var viewProperty = new ViewProperty() { Name = "RichText Title", UiType = "RichText" }; entityView.Add(viewProperty); BizFx uses WYSISWYG Rich text editor. More details here: http://andrewsutherland.azurewebsites.net/2018/10/02/business-tools-ui-hints-and-ui-types/#html


Top 50 recent answers are included